sci-biology/foldingathome: bump to 7.6.13
[gentoo.git] / sci-biology / exonerate / exonerate-2.2.0-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools toolchain-funcs
7
8 DESCRIPTION="Generic tool for pairwise sequence comparison"
9 HOMEPAGE="https://www.ebi.ac.uk/about/vertebrate-genomics/software/exonerate"
10 SRC_URI="http://ftp.ebi.ac.uk/pub/software/vertebrategenomics/exonerate/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
15 IUSE="test threads utils"
16 RESTRICT="!test? ( test )"
17 REQUIRED_USE="test? ( utils )"
18
19 DEPEND="dev-libs/glib:2"
20 RDEPEND="${DEPEND}"
21
22 PATCHES=( "${FILESDIR}"/${P}-asneeded.patch )
23
24 src_prepare() {
25         default
26         sed \
27                 -e 's: -O3 -finline-functions::g' \
28                 -i configure.in || die
29         mv configure.{in,ac} || die
30
31         eautoreconf
32 }
33
34 src_configure() {
35         tc-export CC
36
37         econf \
38                 --enable-glib2 \
39                 --enable-largefile \
40                 $(use_enable utils utilities) \
41                 $(use_enable threads pthreads)
42 }
43
44 src_install() {
45         default
46
47         doman doc/man/man1/*.1
48 }