dev-libs/libinput: stable 1.7.3 for hppa, bug #624312
[gentoo.git] / sci-biology / cutg / cutg-160-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 DESCRIPTION="Codon usage tables calculated from GenBank"
7 HOMEPAGE="http://www.kazusa.or.jp/codon/"
8 SRC_URI="https://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
9
10 SLOT="0"
11 LICENSE="public-domain"
12 # Minimal build keeps only the indexed files (if applicable) and the
13 # documentation. The non-indexed database is not installed.
14 IUSE="emboss minimal"
15 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
16
17 DEPEND="emboss? ( sci-biology/emboss )"
18 RDEPEND="${DEPEND}"
19
20 RESTRICT="binchecks strip"
21
22 src_compile() {
23         if use emboss; then
24                 mkdir CODONS || die
25                 ebegin "Indexing CUTG for usage with EMBOSS."
26                 EMBOSS_DATA="." cutgextract -auto -directory "${S}" || die \
27                         "Indexing CUTG failed."
28                 eend
29         fi
30 }
31
32 src_install() {
33         local file
34         dodoc README CODON_LABEL SPSUM_LABEL
35         if ! use minimal; then
36                 dodir /usr/share/${PN}
37                 mv *.codon *.spsum "${ED}"/usr/share/${PN} || die \
38                         "Installing raw CUTG database failed."
39         fi
40
41         if use emboss; then
42                 dodir /usr/share/EMBOSS/data/CODONS
43                 cd CODONS || die
44                 for file in *; do
45                         mv ${file} "${ED}"/usr/share/EMBOSS/data/CODONS/ || die \
46                                 "Installing the EMBOSS-indexed database failed."
47                 done
48         fi
49 }