sci-biology/poa: Sort KEYWORDS
[gentoo.git] / sci-biology / clustalw-mpi / clustalw-mpi-0.13-r2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="An MPI implemention of the ClustalW general purpose multiple alignment algorithm"
9 HOMEPAGE="http://www.bii.a-star.edu.sg/achievements/applications/clustalw/index.php"
10 SRC_URI="http://web.bii.a-star.edu.sg/~kuobin/${PN}/${P}.tar.gz"
11
12 LICENSE="public-domain"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="mpi_njtree static_pairalign"
16
17 DEPEND="virtual/mpi"
18 RDEPEND="${DEPEND}"
19
20 PATCHES=( "${FILESDIR}"/${PV}-gentoo.patch )
21
22 src_prepare() {
23         default
24
25         if use mpi_njtree; then
26                 sed -e "s/TREES_FLAG/#TREES_FLAG/" -i Makefile || \
27                         die "Failed to configure MPI code for NJ trees"
28         fi
29
30         if use static_pairalign; then
31                 sed -e "s/DDYNAMIC_SCHEDULING/DSTATIC_SCHEDULING/" -i Makefile || \
32                         die "Failed to configure static scheduling for pair alignments"
33         fi
34 }
35
36 src_install() {
37         dobin ${PN}
38         newdoc README.${PN} README
39 }