Merge remote-tracking branch 'remotes/github/pr/115'.
[gentoo.git] / sci-biology / bowtie / bowtie-0.12.8.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="An ultrafast memory-efficient short read aligner"
10 HOMEPAGE="http://bowtie-bio.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/bowtie-bio/${P}-src.zip"
12
13 LICENSE="Artistic"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="amd64 x86 ~x64-macos"
17
18 DEPEND="app-arch/unzip"
19 RDEPEND=""
20
21 # NB: Bundles code from Maq (http://maq.sf.net) and the SeqAn library (http://www.seqan.de)
22 # TODO: properly report system CFLAGS in -DCOMPILE_OPTIONS
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${P}-gcc-47.patch
26 }
27
28 src_compile() {
29         unset CFLAGS
30         emake \
31                 CC="$(tc-getCC)" \
32                 CPP="$(tc-getCXX)" \
33                 CXX="$(tc-getCXX)" \
34                 EXTRA_FLAGS="${LDFLAGS}" \
35                 RELEASE_FLAGS=""
36 }
37
38 src_install() {
39         dobin bowtie bowtie-*
40         exeinto /usr/share/${PN}/scripts
41         doexe scripts/*
42         newman MANUAL bowtie.1
43         dodoc AUTHORS NEWS TUTORIAL
44 }