*/*: Add maintainer-needed comment to all unmaintained packages
[gentoo.git] / sci-biology / bioperl-run / bioperl-run-9999-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit perl-module git-2
7
8 DESCRIPTION="Perl wrapper modules for key bioinformatics applications"
9 HOMEPAGE="http://www.bioperl.org/"
10 SRC_URI=""
11 EGIT_REPO_URI="https://github.com/bioperl/${PN}.git"
12
13 LICENSE="Artistic GPL-2"
14 SLOT="0"
15 KEYWORDS=""
16 IUSE="-minimal test"
17 #SRC_TEST="do"
18
19 RESTRICT="test"
20
21 CDEPEND=">=sci-biology/bioperl-${PV}
22         !minimal? (
23                 dev-perl/Algorithm-Diff
24                 dev-perl/XML-Twig
25                 dev-perl/IO-String
26                 dev-perl/IPC-Run
27         )"
28 DEPEND="dev-perl/Module-Build
29         ${CDEPEND}"
30 RDEPEND="${CDEPEND}"
31
32 S="${WORKDIR}/BioPerl-run-${PV}"
33
34 src_install() {
35         mydoc="AUTHORS BUGS FAQ"
36         perl-module_src_install
37         # TODO: File collision in Bio/ConfigData.pm (a Module::Build internal file)
38         # with sci-biology/bioperl. Workaround: the "nuke it from orbit" solution :D
39         find "${D}" -name '*ConfigData*' -print -delete
40 }