sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / sci-biology / abyss / abyss-2.0.3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools toolchain-funcs
7
8 DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
9 HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
10 SRC_URI="https://github.com/bcgsc/abyss/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="abyss"
13 SLOT="0"
14 IUSE="+mpi openmp misc-haskell"
15 KEYWORDS="~amd64 ~x86"
16
17 RDEPEND="
18         dev-cpp/sparsehash
19         dev-libs/boost:=
20         misc-haskell? (
21                 dev-libs/gmp:0=
22                 virtual/libffi:0=
23         )
24         mpi? ( sys-cluster/openmpi )"
25 DEPEND="${RDEPEND}
26         misc-haskell? (
27                 dev-lang/ghc
28         )"
29
30 # todo: --enable-maxk=N configure option
31 # todo: fix automagic mpi toggling
32
33 pkg_pretend() {
34         [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
35 }
36
37 pkg_setup() {
38         [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
39 }
40
41 src_prepare() {
42         default
43         sed -i -e "s/-Werror//" configure.ac || die #365195
44         sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
45         eautoreconf
46 }
47
48 src_configure() {
49         # disable building haskell tool Misc/samtobreak
50         # unless request by user: bug #534412
51         use misc-haskell || export ac_cv_prog_ac_ct_GHC=
52
53         econf $(use_enable openmp)
54 }