dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / sci-biology / aaindex / aaindex-9.1-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="Amino acid indices and similarity matrices"
7 HOMEPAGE="https://www.genome.jp/aaindex/"
8 SRC_URI="mirror://gentoo/${P}.tar.bz2"
9
10 LICENSE="public-domain"
11 SLOT="0"
12 # Minimal build keeps only the indexed files (if applicable) and the
13 # documentation. The non-indexed database is not installed.
14 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
15 IUSE="emboss minimal"
16
17 DEPEND="emboss? ( sci-biology/emboss )"
18 RDEPEND="${DEPEND}"
19
20 src_compile() {
21         if use emboss; then
22                 mkdir AAINDEX || die
23                 einfo
24                 einfo "Indexing AAindex for usage with EMBOSS."
25                 EMBOSS_DATA="." aaindexextract -auto -infile ${PN}1 || die "Indexing AAindex failed"
26                 einfo
27         fi
28 }
29
30 src_install() {
31         dodoc ${PN}.doc
32
33         if ! use minimal; then
34                 insinto /usr/share/${PN}
35                 doins ${PN}{1,2,3}
36         fi
37
38         if use emboss; then
39                 insinto /usr/share/EMBOSS/data/AAINDEX
40                 doins -r AAINDEX/.
41         fi
42 }