dev-libs/libinput: stable 1.7.3 for hppa, bug #624312
[gentoo.git] / sci-biology / HTSeq / HTSeq-0.9.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Python support for SAM/BAM/Bowtie/FASTA/Q/GFF/GTF files"
11 HOMEPAGE="https://htseq.readthedocs.io/"
12
13 if [[ ${PV} == *9999 ]]; then
14         inherit git-r3
15         EGIT_REPO_URI="https://github.com/simon-anders/htseq.git"
16 else
17         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
18         KEYWORDS="~amd64"
19 fi
20
21 LICENSE="GPL-3+"
22 SLOT="0"
23
24 RDEPEND="
25         dev-python/numpy[${PYTHON_USEDEP}]
26         dev-python/matplotlib[${PYTHON_USEDEP}]
27         sci-biology/pysam[${PYTHON_USEDEP}]"
28 DEPEND="
29         ${RDEPEND}
30         >=dev-lang/swig-3.0.8
31         dev-python/cython[${PYTHON_USEDEP}]"