dev-python/repoze-lru: keyworded 0.7-r1 for ia64, bug #717946
[gentoo.git] / ros-meta / navigation / navigation-9999.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 ROS_REPO_URI="https://github.com/ros-planning/navigation"
6 KEYWORDS="~amd64 ~arm"
7 ROS_SUBDIR=${PN}
8
9 inherit ros-catkin
10
11 DESCRIPTION="2D navigation stack"
12 LICENSE="BSD LGPL-2.1"
13 SLOT="0"
14 IUSE=""
15
16 RDEPEND="
17         dev-ros/amcl
18         dev-ros/base_local_planner
19         dev-ros/carrot_planner
20         dev-ros/clear_costmap_recovery
21         dev-ros/costmap_2d
22         dev-ros/dwa_local_planner
23         dev-ros/fake_localization
24         dev-ros/global_planner
25         dev-ros/map_server
26         dev-ros/move_base
27         dev-ros/move_slow_and_clear
28         dev-ros/nav_core
29         dev-ros/navfn
30         dev-ros/rotate_recovery
31         dev-ros/voxel_grid
32 "
33 DEPEND="${RDEPEND}"