*/*: downgrade m68k down to ~m68k
[gentoo.git] / perl-core / Math-BigInt / Math-BigInt-1.999.806.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DIST_AUTHOR=PJACKLAM
7 DIST_VERSION=1.999806
8 DIST_EXAMPLES=("examples/*")
9 inherit perl-module
10
11 DESCRIPTION="Arbitrary size floating point math package"
12
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="test"
16 RESTRICT="!test? ( test )"
17
18 RDEPEND="
19         >=virtual/perl-Math-Complex-1.390.0
20 "
21 DEPEND="${RDEPEND}
22         virtual/perl-ExtUtils-MakeMaker
23         test? ( >=virtual/perl-Test-Simple-0.940.0 )
24 "
25
26 PDEPEND="
27         >=virtual/perl-Math-BigInt-FastCalc-0.270.0
28         >=virtual/perl-bignum-0.220.0
29         >=virtual/perl-Math-BigRat-0.260.200
30 "
31 # where does this come from?
32
33 src_test() {
34         perl_rm_files t/author-*.t t/03podcov.t t/00sig.t t/02pod.t
35         perl-module_src_test
36 }