www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / net-wireless / soapysdrplay / soapysdrplay-0.2.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit cmake-utils
7
8 DESCRIPTION="Soapy SDR plugin for SDRPlay"
9 HOMEPAGE="https://github.com/pothosware/SoapySDRPlay"
10
11 if [ "${PV}" = "9999" ]; then
12         EGIT_REPO_URI="https://github.com/pothosware/SoapySDRPlay.git"
13         EGIT_CLONE_TYPE="shallow"
14         inherit git-r3
15 else
16         KEYWORDS="~amd64 ~x86"
17         SRC_URI="https://github.com/pothosware/SoapySDRPlay/archive/soapy-sdrplay-${PV}.tar.gz -> ${P}.tar.gz"
18         S="${WORKDIR}"/SoapySDRPlay-soapy-sdrplay-"${PV}"
19 fi
20
21 LICENSE="Boost-1.0"
22 SLOT="0"
23
24 IUSE=""
25 REQUIRED_USE=""
26
27 RDEPEND="net-wireless/soapysdr
28         net-wireless/sdrplay"
29 DEPEND="${RDEPEND}"