net-wireless/blueman: Remove redundant versions
[gentoo.git] / net-wireless / python-wifi / python-wifi-0.5.0-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 PYTHON_COMPAT=( python2_7 )
7
8 inherit distutils-r1
9
10 DESCRIPTION="Provides r/w access to a wireless network card's capabilities"
11 HOMEPAGE="https://pypi.org/project/python-wifi/"
12 SRC_URI="mirror://sourceforge/${PN}.berlios/${P}.tar.bz2"
13
14 SLOT="0"
15 KEYWORDS="~alpha amd64 ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86"
16 LICENSE="LGPL-2.1 examples? ( GPL-2 )"
17 IUSE="examples"
18
19 RDEPEND=""
20 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
21
22 DOCS=( docs/AUTHORS docs/BUGS docs/DEVEL.txt docs/TODO )
23
24 src_install() {
25         distutils-r1_src_install
26         use examples && dodoc -r examples
27         rm -rv "${ED}"/usr/{docs,examples,INSTALL,README} || die
28         if use examples; then
29                 mv -v "${ED}"/usr{,/share}/man || die
30         else
31                 rm -rv "${ED}"/usr/man || die
32         fi
33 }