dev-python/pip: arm64 stable (bug #719946)
[gentoo.git] / net-wireless / hidclient / hidclient-20120728.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit epatch
7
8 DESCRIPTION="Use your machine as a bluetooh keyboard/mouse"
9 HOMEPAGE="http://anselm.hoffmeister.be/computer/hidclient/"
10 SRC_URI="http://anselm.hoffmeister.be/computer/${PN}/${P}.tar.bz2"
11
12 LICENSE="GPL-2+"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="net-wireless/bluez"
18 RDEPEND="${DEPEND}
19         x11-apps/xinput"
20
21 S="${WORKDIR}"
22
23 src_prepare() {
24         epatch "${FILESDIR}"/${P}-glibc-2.30.patch
25         sed -i 's#gcc#$(CC)#' Makefile
26         sed -i 's#-O2#$(CFLAGS) $(LDFLAGS)#' Makefile
27 }
28
29 src_compile() {
30         emake hidclient
31 }
32
33 src_install() {
34         dosbin hidclient
35         dodoc "${FILESDIR}"/README
36 }