dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / net-wireless / crackle / crackle-9999.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils
7
8 DESCRIPTION="Crackle cracks BLE Encryption (AKA Bluetooth Smart)"
9 HOMEPAGE="http://lacklustre.net/projects/crackle/"
10
11 if [[ ${PV} == "9999" ]] ; then
12         EGIT_REPO_URI="https://github.com/mikeryan/crackle.git"
13         inherit git-r3
14         KEYWORDS=""
15 else
16         SRC_URI="http://lacklustre.net/projects/crackle/${P}.tgz"
17         KEYWORDS="~amd64 ~x86"
18 fi
19
20 LICENSE="BSD"
21 SLOT="0"
22 IUSE="test"
23 RESTRICT="!test? ( test )"
24
25 RDEPEND="net-libs/libpcap"
26 DEPEND="${RDEPEND}
27                 test? ( dev-lang/perl )"
28
29 src_install() {
30         DESTDIR="${ED}" PREFIX=/usr emake install
31 }