sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / net-wireless / bss / bss-0.8-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="Bluetooth stack smasher / fuzzer"
9 HOMEPAGE="http://securitech.homeunix.org/blue/"
10 SRC_URI="http://securitech.homeunix.org/blue/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc ~x86"
15 IUSE=""
16
17 DEPEND="net-wireless/bluez"
18
19 src_prepare() {
20         default
21         sed -i -e 's:/local::' Makefile || die
22 }
23
24 src_compile() {
25         emake \
26                 CC="$(tc-getCC)" \
27                 CFLAGS="${CFLAGS}" \
28                 BSS_FLAGS="${LDFLAGS}"
29 }
30
31 src_install() {
32         dosbin bss
33         dodoc AUTHOR BUGS CHANGELOG CONTRIB NOTES README TODO \
34                 replay_packet/replay_l2cap_packet.c
35 }