net-libs/nodejs: Versions 10.17.0 13.0.0
[gentoo.git] / net-vpn / tinc / tinc-1.0.36.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit systemd
6
7 DESCRIPTION="tinc is an easy to configure VPN implementation"
8 HOMEPAGE="http://www.tinc-vpn.org/"
9
10 SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
15 IUSE="libressl +lzo uml vde +zlib"
16
17 DEPEND="
18         !libressl? ( dev-libs/openssl:0= )
19         libressl? ( dev-libs/libressl:0= )
20         lzo? ( dev-libs/lzo:2 )
21         zlib? ( sys-libs/zlib )"
22 RDEPEND="${DEPEND}
23         vde? ( net-misc/vde )"
24
25 src_configure() {
26         econf \
27                 --enable-jumbograms \
28                 --disable-tunemu  \
29                 $(use_enable lzo) \
30                 $(use_enable uml) \
31                 $(use_enable vde) \
32                 $(use_enable zlib)
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install
37         dodir /etc/tinc
38         dodoc AUTHORS NEWS README THANKS
39         doconfd "${FILESDIR}"/tinc.networks
40         newconfd "${FILESDIR}"/tincd.conf tincd
41         newinitd "${FILESDIR}"/tincd-r1 tincd
42         systemd_newunit "${FILESDIR}"/tincd_at.service "tincd@.service"
43 }