net-vpn/openconnect: arm keyworded
[gentoo.git] / net-vpn / corkscrew / corkscrew-2.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit autotools
6
7 DESCRIPTION="a tool for tunneling SSH through HTTP proxies"
8 HOMEPAGE="http://www.agroman.net/corkscrew/"
9 SRC_URI="http://www.agroman.net/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~arm ~ppc ~sparc x86"
14 IUSE=""
15
16 DOCS="AUTHORS ChangeLog README TODO"
17
18 src_prepare() {
19         # Christoph Mende <angelos@gentoo.org (23 Jun 2010)
20         # Shipped configure doesn't work with some locales (bug #305771)
21         # Shipped missing doesn't work with new configure, so we'll force
22         # regeneration
23         rm -f install-sh missing mkinstalldirs || die
24
25         # Samuli Suominen <ssuominen@gentoo.org> (24 Jun 2012)
26         # AC_HEADER_STDC is called separately and #include <string.h> is
27         # without #ifdef in corkscrew.c. Instead of using AC_C_PROTOTYPES,
28         # remove the call entirely as unused wrt bug #423193
29         sed -i -e 's:AM_C_PROTOTYPES:dnl &:' configure.in || die
30
31         eautoreconf
32 }