net-proxy/torsocks: add an `|| die`
[gentoo.git] / net-proxy / torsocks / torsocks-2.1.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit autotools eutils multilib versionator
8
9 MY_PV="$(replace_version_separator 3 -)"
10 MY_PF="${PN}-${MY_PV}"
11 S=${WORKDIR}/${MY_PF}
12
13 DESCRIPTION="Use most socks-friendly applications with Tor"
14 HOMEPAGE="https://github.com/dgoulet/torsocks"
15 SRC_URI="https://github.com/dgoulet/torsocks/archive/v${MY_PV}.tar.gz -> ${MY_PF}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~arm ~x86"
20 IUSE="static-libs"
21
22 # We do not depend on tor which might be running on a different box
23 DEPEND=""
24 RDEPEND="${DEPEND}"
25
26 src_prepare() {
27         sed -i -e "/dist_doc_DATA/s/^/#/" Makefile.am doc/Makefile.am || die
28
29         # Disable tests requiring network access.
30         sed -i -e '/^\.\/test_dns$/d' tests/test_list || \
31                 die "failed to disable network tests"
32
33         eautoreconf
34 }
35
36 src_configure() {
37         econf $(use_enable static-libs static)
38 }
39
40 src_install() {
41         default
42
43         dodoc ChangeLog README.md TODO doc/notes/DEBUG doc/socks/{SOCKS5,socks-extensions.txt}
44
45         #Remove libtool .la files
46         cd "${D}"/usr/$(get_libdir)/torsocks || die
47         rm -f *.la
48 }