net-proxy/havp: remove old version
[gentoo.git] / net-proxy / sshuttle / sshuttle-0.76.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_7,3_5} )
7
8 inherit eutils linux-info distutils-r1
9
10 DESCRIPTION="Transparent proxy server that works as a poor man's VPN using ssh"
11 HOMEPAGE="https://github.com/sshuttle/sshuttle https://pypi.python.org/pypi/sshuttle"
12 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="GPL-2+"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="test"
18
19 RDEPEND="
20         dev-python/setuptools[${PYTHON_USEDEP}]
21         net-firewall/iptables
22 "
23 DEPEND="
24         dev-python/setuptools_scm[${PYTHON_USEDEP}]
25         test? (
26                 dev-python/pytest[${PYTHON_USEDEP}]
27                 dev-python/mock[${PYTHON_USEDEP}]
28         )
29 "
30
31 CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~NF_NAT"
32
33 python_test() {
34         py.test || die "Tests fail under ${EPYTHON}"
35 }