72235cfd104c590274095e6462e55fee569b6b25
[gentoo.git] / net-proxy / ratproxy / ratproxy-1.58.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils flag-o-matic
5
6 DESCRIPTION="A semi-automated, largely passive web application security audit tool"
7 HOMEPAGE="https://code.google.com/p/ratproxy/"
8 SRC_URI="https://ratproxy.googlecode.com/files/${P}.tar.gz"
9
10 LICENSE="Apache-2.0"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14
15 DEPEND="dev-libs/openssl"
16 RDEPEND="${DEPEND}"
17
18 S="${WORKDIR}"/${PN}
19
20 src_unpack() {
21         unpack ${A}
22         cd "${S}"
23
24         sed -i -e "s:keyfile\.pem:/usr/share/${PN}/&:" ssl.c
25         sed -r -i -e "s:(ratproxy-back\.png|messages\.list):/usr/share/${PN}/&:" ratproxy-report.sh
26         epatch "${FILESDIR}"/${PN}-Makefile.patch
27 }
28
29 src_compile() {
30         tc-export CC
31
32         emake || die "emake failed"
33 }
34
35 src_install() {
36         dobin ${PN}-report.sh || die "install failed"
37         dobin ${PN} || die "install failed"
38         dodoc doc/{README,TODO}
39         insinto /usr/share/${PN}
40         doins keyfile.pem ratproxy-back.png messages.list
41 }