net-proxy/haproxy: 9999-style builds for current major versions.
[gentoo.git] / net-proxy / pingtunnel / pingtunnel-0.72.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils toolchain-funcs
8
9 DESCRIPTION="Tunnel TCP over ICMP"
10 HOMEPAGE="http://www.cs.uit.no/~daniels/PingTunnel"
11 SRC_URI="http://www.cs.uit.no/~daniels/PingTunnel/PingTunnel-${PV}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~ppc ~sh ~x86"
16 IUSE="doc selinux"
17
18 DEPEND="
19         net-libs/libpcap
20         selinux? ( sys-libs/libselinux )
21 "
22 RDEPEND="${DEPEND}"
23
24 S="${WORKDIR}"/PingTunnel
25
26 src_prepare(){
27         epatch "${FILESDIR}"/${P}_makefile.patch
28 }
29
30 src_compile() {
31         tc-export CC
32         emake $(usex selinux "SELINUX=1" "SELINUX=0")
33 }
34
35 src_install() {
36         default
37         use doc && dohtml web/*
38 }