dev-qt/qthelp: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-proxy / mitmproxy / mitmproxy-4.0.4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_6 )
7 inherit distutils-r1
8
9 DESCRIPTION="An interactive, SSL-capable, man-in-the-middle HTTP proxy"
10 HOMEPAGE="https://mitmproxy.org/"
11 SRC_URI="https://github.com/mitmproxy/mitmproxy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 RDEPEND="
19         >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
20         >=dev-python/brotlipy-0.7.0[${PYTHON_USEDEP}]
21         >=dev-python/certifi-2015.11.20.1[${PYTHON_USEDEP}]
22         >=dev-python/click-6.2[${PYTHON_USEDEP}]
23         >=dev-python/cryptography-2.1.4[${PYTHON_USEDEP}]
24         >=dev-python/hyper-h2-3.0.1[${PYTHON_USEDEP}]
25         >=dev-python/hyperframe-5.1.0[${PYTHON_USEDEP}]
26         >=dev-python/kaitaistruct-0.7[${PYTHON_USEDEP}]
27         >=dev-python/ldap3-2.5[${PYTHON_USEDEP}]
28         >=dev-python/passlib-1.6.5[${PYTHON_USEDEP}]
29         >=dev-python/protobuf-python-3.6.0[${PYTHON_USEDEP}]
30         >=dev-python/pyasn1-0.3.1[${PYTHON_USEDEP}]
31         >=dev-python/pyopenssl-17.5[${PYTHON_USEDEP}]
32         >=dev-python/pyparsing-2.1.3[${PYTHON_USEDEP}]
33         >=dev-python/pyperclip-1.6.0[${PYTHON_USEDEP}]
34         >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
35         >=dev-python/ruamel-yaml-0.15[${PYTHON_USEDEP}]
36         >=dev-python/sortedcontainers-1.5.4[${PYTHON_USEDEP}]
37         >=www-servers/tornado-4.3[${PYTHON_USEDEP}]
38         >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
39         >=dev-python/wsproto-0.11.0[${PYTHON_USEDEP}]
40 "
41
42 DEPEND="${RDEPEND}
43         dev-python/setuptools[${PYTHON_USEDEP}]
44         test? (
45                 >=dev-python/flask-1.0[${PYTHON_USEDEP}]
46                 >=dev-python/parver-0.1[${PYTHON_USEDEP}]
47                 >=dev-python/pytest-3.3[${PYTHON_USEDEP}]
48                 >=dev-python/requests-2.9.1[${PYTHON_USEDEP}]
49         )"
50
51 RESTRICT="!test? ( test )"
52
53 python_prepare_all() {
54         # loosen dependencies
55         sed -i '/>/s/>.*/",/g' setup.py || die
56
57         # remove failing tests
58         sed -e 's/test_iframe_injector/_&/g' \
59                 -i test/examples/test_examples.py || die
60
61         sed -e 's/test_find_unclaimed_URLs/_&/g' \
62                 -i test/examples/test_xss_scanner.py || die
63
64         rm test/mitmproxy/addons/test_readfile.py || die
65
66         sed \
67                 -e 's/test_mode_none_should_pass_without_sni/_&/g' \
68                 -e 's/test_mode_strict_w_pemfile_should_pass/_&/g' \
69                 -e 's/test_mode_strict_w_confdir_should_pass/_&/g' \
70                 -i test/mitmproxy/net/test_tcp.py || die
71
72         sed \
73                 -e 's/test_verification_w_confdir/_&/g' \
74                 -e 's/test_verification_w_pemfile/_&/g' \
75                 -i test/mitmproxy/proxy/test_server.py || die
76
77         # needs pytest-asyncio
78         rm test/mitmproxy/tools/test_main.py || die
79
80         distutils-r1_python_prepare_all
81 }
82
83 python_test() {
84         pytest -vv || die
85 }