Use https by default
[gentoo.git] / net-print / sshlpr / sshlpr-1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="4"
6
7 DESCRIPTION="ssh-lpr backend for cups -- print to remote systems over ssh"
8 HOMEPAGE="http://www.masella.name/technical/sshlpr.html"
9 SRC_URI="https://dev.gentoo.org/~radhermit/distfiles/${P}.tar.gz"
10
11 LICENSE="public-domain"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="net-print/cups"
17 RDEPEND="${DEPEND}
18         net-misc/openssh
19         sys-apps/shadow"
20
21 S="${WORKDIR}"
22
23 src_install() {
24         exeinto $(cups-config --serverbin)/backend
25         exeopts -m0700
26         doexe ${PN}
27 }