profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / net-print / pnm2ppa / pnm2ppa-1.13-r1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 inherit base
7
8 DESCRIPTION="Print driver for Hp Deskjet 710, 712, 720, 722, 820, 1000 series"
9 HOMEPAGE="http://pnm2ppa.sourceforge.net"
10 SRC_URI="mirror://sourceforge/pnm2ppa/${P}.tar.gz"
11
12 KEYWORDS="~amd64 ~x86"
13 SLOT="0"
14 LICENSE="GPL-2"
15 IUSE="syslog"
16
17 # en on first place so others can override it
18 LANGS="en cs es fr it nl"
19 for lng in ${LANGS}; do
20         IUSE+=" l10n_${lng}"
21 done
22
23 RDEPEND="
24         app-text/ghostscript-gpl
25         net-print/cups
26         >=net-print/cups-filters-1.0.43-r1[foomatic]
27         sys-libs/glibc
28         syslog? ( virtual/logger )
29 "
30 DEPEND="${RDEPEND}"
31
32 src_configure() {
33         local lng i withval
34
35         for lng in ${LANGS}; do
36                 if use l10n_${lng}; then
37                         if [[ -n ${i} ]] ; then
38                                 ewarn "This package supports only one translation at a time."
39                                 ewarn "Overriding previous value: \"${withval}\" with \"${lng}\""
40                         fi
41                         withval="${lng}"
42                         i=true
43                 fi
44         done
45
46         econf \
47                 --with-language="${lng}" \
48                 --enable-vlink \
49                 $(use_enable syslog)
50 }
51
52 src_install() {
53         default
54
55         dobin utils/Linux/detect_ppa utils/Linux/test_ppa
56
57         insinto /usr/share/pnm2ppa
58         doins -r lpd pdq
59
60         exeinto /usr/share/pnm2ppa/lpd
61         doexe lpd/lpdsetup
62
63         exeinto /usr/share/pnm2ppa/sample_scripts
64         doexe sample_scripts/*
65
66         exeinto /etc/pdq/drivers/ghostscript
67         doexe pdq/gs-pnm2ppa
68         exeinto /etc/pdq/interfaces
69         doexe pdq/dummy
70
71         # install docs
72         cd docs/en
73         dodoc CALIBRATION*txt COLOR*txt PPA*txt RELEASE* CREDITS README sgml/*.sgml
74
75         cd "${S}"
76         dohtml -r .
77 }