profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / net-print / gtklp / gtklp-1.3.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils
7
8 DESCRIPTION="A GUI for cupsd"
9 HOMEPAGE="https://gtklp.sirtobi.com/"
10 SRC_URI="mirror://sourceforge/gtklp/${P}.src.tar.gz
11         mirror://sourceforge/gtklp/logo.xpm.gz -> gtklp-logo.xpm.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="amd64 ppc ~sparc x86"
16 IUSE="nls ssl"
17
18 RDEPEND="x11-libs/gtk+:2
19         net-print/cups
20         nls? ( sys-devel/gettext )
21         ssl? ( dev-libs/openssl:0= )"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig"
24
25 DOCS="AUTHORS BUGS ChangeLog README TODO USAGE"
26
27 PATCHES=( "${FILESDIR}/${P}-formatsec.patch" )
28
29 src_prepare() {
30         default
31         sed -e '/DEF_BROWSER_CMD/{s:netscape:firefox:}' \
32                 -e '/DEF_HELP_HOME/{s:631/sum.html#STANDARD_OPTIONS:631/help/:}' \
33                 -i include/defaults.h || die
34         eautoreconf
35 }
36
37 src_configure() {
38         econf \
39                 $(use_enable nls) \
40                 $(use_enable ssl) \
41                 --enable-forte #369003
42 }
43
44 src_install() {
45         default
46
47         doicon "${WORKDIR}"/gtklp-logo.xpm
48         make_desktop_entry 'gtklp -i' "Print files via CUPS" gtklp-logo 'System;HardwareSettings;Settings;Printing'
49         make_desktop_entry gtklpq "CUPS queue manager" gtklp-logo 'System;HardwareSettings;Settings;Printing'
50 }