net-misc/iputils: Merge GitHub PR #2289
[gentoo.git] / net-p2p / transmission-remote-gtk / transmission-remote-gtk-1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6 inherit gnome2-utils
7
8 DESCRIPTION="GTK client for management of the Transmission BitTorrent client, over HTTP RPC"
9 HOMEPAGE="https://code.google.com/p/transmission-remote-gtk"
10 SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="debug geoip libproxy unique"
16 RESTRICT="test"
17
18 RDEPEND=">=dev-libs/glib-2.22:2
19         >=dev-libs/json-glib-0.12.2
20         unique? ( dev-libs/libunique:1 )
21         libproxy? ( net-libs/libproxy )
22         net-misc/curl
23         >=x11-libs/gtk+-2.16:2
24         x11-libs/libnotify
25         geoip? ( dev-libs/geoip )"
26 DEPEND="${RDEPEND}
27         dev-util/intltool
28         virtual/pkgconfig"
29
30 DOCS=( AUTHORS README )
31
32 src_configure() {
33         # disable gtk3 for now because upstream doesn't consider it "ready".
34         # Also disable libappindicator till gtk3 is ready since ayatana on
35         # gtk2 is deprecated in Gentoo.
36         econf \
37                 $(use_enable debug) \
38                 $(use_with geoip libgeoip) \
39                 $(use_with libproxy) \
40                 $(use_with unique libunique) \
41                 --without-libappindicator \
42                 --disable-gtk3
43 }
44
45 pkg_preinst() { gnome2_icon_savelist; }
46 pkg_postinst() { gnome2_icon_cache_update; }
47 pkg_postrm() { gnome2_icon_cache_update; }