net-p2p/torrentinfo: add myself as maintainer, fix tests, add py3.6, pypy{,3}
[gentoo.git] / net-p2p / torrentinfo / torrentinfo-1.8.6-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
6
7 inherit distutils-r1
8
9 DESCRIPTION="A torrent file parser"
10 HOMEPAGE="https://github.com/Fuuzetsu/torrentinfo"
11 SRC_URI="https://github.com/Fuuzetsu/torrentinfo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="GPL-2+"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="test"
17
18 DEPEND="
19         dev-python/setuptools[${PYTHON_USEDEP}]
20         test? ( dev-python/nose[${PYTHON_USEDEP}] )
21 "
22
23 PATCHES=( "${FILESDIR}/${P}-fix-tests.patch" )
24
25 python_test() {
26         nosetests test/tests.py || die "tests failed with ${EPYTHON}"
27 }