net-p2p/qbittorrent: amd64 stable wrt bug #653976
[gentoo.git] / net-p2p / mktorrent / mktorrent-1.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit toolchain-funcs
6
7 DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
8 HOMEPAGE="https://github.com/Rudde/mktorrent"
9
10 if [[ ${PV} == *9999 ]]; then
11         inherit git-r3
12         EGIT_REPO_URI="https://github.com/Rudde/mktorrent.git"
13 else
14         SRC_URI="https://github.com/Rudde/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15         KEYWORDS="~amd64 ~arm ~x86"
16 fi
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 KEYWORDS="~amd64 ~arm ~x86"
21 IUSE="threads +ssl debug"
22
23 RDEPEND="ssl? ( dev-libs/openssl:0= )"
24 DEPEND="${RDEPEND}"
25
26 src_compile() {
27         tc-export CC
28
29         emake \
30                 USE_LONG_OPTIONS=1 \
31                 USE_LARGE_FILES=1 \
32                 DEBUG=$(usex debug) \
33                 USE_OPENSSL=$(usex ssl) \
34                 USE_PTHREADS=$(usex threads)
35 }
36
37 src_install() {
38         dobin ${PN}
39         dodoc README
40 }