net-p2p/torrentinfo: amd64 stable wrt bug #721410
[gentoo.git] / net-p2p / mktorrent / mktorrent-1.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit toolchain-funcs
6
7 DESCRIPTION="Simple command line utility to create BitTorrent metainfo files"
8 HOMEPAGE="http://mktorrent.sourceforge.net"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="amd64 x86"
14 IUSE="threads +ssl debug"
15
16 RDEPEND="ssl? ( dev-libs/openssl:0 )"
17 DEPEND="${RDEPEND}"
18
19 src_compile() {
20         tc-export CC
21         MAKEPARAM="USE_LONG_OPTIONS=1"
22         MAKEPARAM="${MAKEPARAM} USE_LARGE_FILES=1"
23         use debug && MAKEPARAM="${MAKEPARAM} DEBUG=1"
24         use ssl && MAKEPARAM="${MAKEPARAM} USE_OPENSSL=1"
25         use threads && MAKEPARAM="${MAKEPARAM} USE_PTHREADS=1"
26
27         emake ${MAKEPARAM}
28 }
29
30 src_install() {
31         dobin ${PN}
32         dodoc README
33 }