Use https by default
[gentoo.git] / net-p2p / imule / imule-2.3.2.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 WX_GTK_VER="2.8"
7 inherit wxwidgets
8
9 MY_PN="iMule"
10
11 DESCRIPTION="P2P sharing software which connects through I2P and Kad network"
12 # New homepage has a few resources and a working nodes.dat file users need
13 # in order to get iMule to work
14 HOMEPAGE="http://echelon.i2p/imule"
15 SRC_URI="http://echelon.i2p/imule/${PV}/${MY_PN}-${PV}-src.tbz https://dev.gentoo.org/~zlg/extra/net-p2p/imule/2015-03-22_nodes.dat"
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="webserver static-libs nls"
20
21 # wxGTK 2.8 is required; later versions result in failed compile
22 # Other versions indicated are from the tarball's INSTALL file
23 DEPEND="x11-libs/wxGTK:2.8
24         net-p2p/i2p
25         >=net-libs/libupnp-1.6.6
26         sys-devel/flex
27         sys-apps/texinfo
28         >=dev-libs/crypto++-5.1"
29 RDEPEND="x11-libs/wxGTK:2.8 net-p2p/i2p"
30
31 S="${WORKDIR}/${MY_PN}-${PV}-src"
32
33 src_configure() {
34         WX_GTK_VER="2.8" need-wxwidgets unicode
35         # Enabling imulecmd results in a compilation error.
36         econf --with-wx-config=${WX_CONFIG} \
37                 --enable-imule-daemon \
38                 --enable-alc \
39                 --enable-alcc \
40                 --enable-optimize \
41                 --disable-debug \
42                 $(use_enable nls) \
43                 $(use_enable webserver) \
44                 $(use_enable static-libs static)
45 }
46
47 pkg_postinst() {
48         elog "iMule will not function without a valid 'nodes.dat' file and"
49         elog "an I2P router running."
50         elog "The nodes.dat file can be found at http://echelon.i2p/imule."
51 }