Use https by default
[gentoo.git] / net-p2p / imule / imule-2.3.2.3-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 WX_GTK_VER="2.8"
7 inherit wxwidgets
8
9 MY_PN="iMule"
10
11 DESCRIPTION="P2P sharing software which connects through I2P and Kad networks"
12 # New homepage has a few resources and a working nodes.dat file users need
13 # in order to get iMule to work
14 HOMEPAGE="http://echelon.i2p/imule"
15 SRC_URI="https://dev.gentoo.org/~zlg/extra/net-p2p/imule/${MY_PN}-${PV}-src.tbz https://dev.gentoo.org/~zlg/extra/net-p2p/imule/2015-03-22_nodes.dat"
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="webserver static-libs nls"
20 RESTRICT="mirror"
21
22 # wxGTK 2.8 is required; later versions result in failed compile
23 # Other versions indicated are from the tarball's INSTALL file
24 DEPEND="x11-libs/wxGTK:2.8
25         net-p2p/i2p
26         >=net-libs/libupnp-1.6.6
27         sys-devel/flex
28         sys-apps/texinfo
29         >=dev-libs/crypto++-5.1
30         !net-p2p/amule"
31 RDEPEND="x11-libs/wxGTK:2.8 net-p2p/i2p"
32
33 S="${WORKDIR}/${MY_PN}-${PV}-src"
34
35 src_unpack() {
36         default
37         cp "${DISTDIR}"/2015-03-22_nodes.dat "${WORKDIR}"
38 }
39
40 src_configure() {
41         WX_GTK_VER="2.8" need-wxwidgets unicode
42         # Enabling imulecmd results in a compilation error.
43         econf --with-wx-config=${WX_CONFIG} \
44                 --enable-imule-daemon \
45                 --enable-alc \
46                 --enable-alcc \
47                 --enable-optimize \
48                 --disable-debug \
49                 $(use_enable nls) \
50                 $(use_enable webserver) \
51                 $(use_enable static-libs static)
52 }
53
54 src_install() {
55         default
56         insinto /usr/share/${PN}
57         newins "${WORKDIR}"/2015-03-22_nodes.dat nodes.dat
58 }
59
60 pkg_postinst() {
61         elog "iMule will not function without a valid 'nodes.dat' file and"
62         elog "an I2P router running."
63         elog "A nodes.dat file can be found in /usr/share/imule. It can"
64         elog "be copied to ~/.iMule/nodes.dat for convenience."
65 }