dev-ros/rosbash: Fix catking prefix patch.
[gentoo.git] / net-p2p / hx / hx-0.4.11.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit autotools
6
7 LICENSE="GPL-2"
8 KEYWORDS="ppc ~sparc x86"
9 MY_P=mhxd-${PV}
10
11 DESCRIPTION="This is a Hotline 1.5+ compatible *nix Hotline Client in CLI. It supports IRC compatibility"
12 SRC_URI="http://projects.acidbeats.de/${MY_P}.tar.bz2"
13 HOMEPAGE="http://hotlinex.sf.net/"
14
15 IUSE="ssl"
16
17 DEPEND="
18         ssl? ( >=dev-libs/openssl-0.9.6d )
19         >=sys-libs/zlib-1.1.4"
20
21 SLOT="0"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_unpack() {
26         unpack ${A}
27
28         cd "${S}"
29         eautoreconf
30 }
31
32 src_compile() {
33         econf \
34         `use_enable ssl idea` \
35         `use_enable ssl cipher` \
36         `use_enable ssl hope` \
37         `use_enable ssl compress` \
38         --enable-hx || die "bad configure"
39         emake || die "compile problem"
40         make install || die "compile problem"
41 }
42
43 src_install() {
44         dodoc AUTHORS INSTALL PROBLEMS README* ChangeLog TODO NEWS run/hx/ghxvars run/hx/ghxvars.jp \
45         run/hx/hxrc run/hx/hxvars
46
47         dobin run/hx/bin/hx
48 }