net-p2p/cpuminer-opt: 3.10.6 version bump
[gentoo.git] / net-p2p / ctorrent / ctorrent-3.3.2-r4.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 MY_P="${PN}-dnh${PV}"
7
8 DESCRIPTION="Enhanced CTorrent is a BitTorrent console client written in C and C++"
9 HOMEPAGE="http://www.rahul.net/dholmes/ctorrent/"
10 SRC_URI="mirror://sourceforge/dtorrent/${MY_P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 arm ppc ~s390 ~sh ~sparc x86"
15 IUSE="libressl"
16
17 S="${WORKDIR}/${MY_P}"
18
19 RDEPEND="
20         libressl? ( dev-libs/libressl:0= )
21         !libressl? ( dev-libs/openssl:0= )
22 "
23 DEPEND="${RDEPEND}"
24
25 PATCHES=(
26         "${FILESDIR}"/${PN}-CVE-2009-1759.patch
27         "${FILESDIR}"/${P}-negative-ints.patch
28         "${FILESDIR}"/${P}-empty-path-components.patch
29 )