Merge github#363: sys-process/atop: add systemd support
[gentoo.git] / net-nds / shelldap / shelldap-1.3.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit eutils perl-app
8
9 DESCRIPTION="A handy shell-like interface for browsing LDAP servers and editing their content"
10 HOMEPAGE="http://projects.martini.nu/shelldap/"
11 SRC_URI="http://code.martini.nu/shelldap/archive/v${PV}.tar.bz2 -> ${P}.tar.bz2"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16
17 DEPEND=""
18 RDEPEND="dev-perl/Algorithm-Diff
19         dev-perl/perl-ldap
20         dev-perl/TermReadKey
21         dev-perl/Term-ReadLine-Gnu
22         dev-perl/Term-Shell
23         dev-perl/YAML-Syck
24         virtual/perl-Digest-MD5"
25
26 S="${WORKDIR}/${PN}-v${PV}"
27
28 src_prepare() {
29         epatch_user
30 }
31
32 src_configure() { :; }
33
34 src_compile() {
35         pod2man --name "${PN}" < "${PN}" > "${PN}.1" || die 'creating manpage failed'
36 }
37
38 src_install() {
39         doman "${PN}.1"
40         dobin "${PN}"
41 }