net-misc/youtube-dl: Old.
[gentoo.git] / net-misc / youtube-dl / youtube-dl-99999999.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
8 DISTUTILS_SINGLE_IMPL=true
9 inherit bash-completion-r1 distutils-r1 eutils git-r3
10
11 DESCRIPTION="Download videos from YouTube.com (and more sites...)"
12 HOMEPAGE="https://rg3.github.com/youtube-dl/"
13 EGIT_REPO_URI="https://github.com/rg3/youtube-dl.git"
14
15 LICENSE="public-domain"
16 SLOT="0"
17 KEYWORDS=""
18 IUSE="test"
19
20 DEPEND="
21         dev-python/setuptools[${PYTHON_USEDEP}]
22         dev-python/sphinx[${PYTHON_USEDEP}]
23         test? ( dev-python/nose[coverage(+)] )
24 "
25
26 src_compile() {
27         distutils-r1_src_compile
28         emake -C docs man
29         ${PYTHON} devscripts/bash-completion.py
30 }
31
32 src_test() {
33         emake test
34 }
35
36 src_install() {
37         python_domodule youtube_dl
38         dobin bin/${PN}
39         dodoc README.md
40         doman docs/_build/man/${PN}.1
41         newbashcomp ${PN}.bash-completion ${PN}
42         python_fix_shebang "${ED}"
43 }