app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / whatportis / whatportis-0.6.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_{4,5}} )
7
8 inherit distutils-r1 eutils
9
10 DESCRIPTION="A command to search port names and numbers"
11 HOMEPAGE="https://github.com/ncrocfer/whatportis http://pypi.python.org/pypi/whatportis"
12 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
13
14 LICENSE="MIT"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
17 IUSE="test"
18
19 RDEPEND="
20         >=dev-python/click-6.2[${PYTHON_USEDEP}]
21         >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
22         >=dev-python/tinydb-3.1.2[${PYTHON_USEDEP}]
23         >=dev-python/simplejson-3.8.1[${PYTHON_USEDEP}]
24 "
25 DEPEND="${RDEPEND}
26         dev-python/setuptools[${PYTHON_USEDEP}]"
27
28 python_test() {
29         "${EPYTHON}" test_${PN}.py || die
30 }
31
32 pkg_postinst() {
33         optfeature "Run ${PN} as a Server" dev-python/flask
34 }