net-misc/dropbear: arm stable, bug #577050
[gentoo.git] / net-misc / whatportis / whatportis-0.2.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="A command to search port names and numbers"
12 HOMEPAGE="https://github.com/ncrocfer/whatportis http://pypi.python.org/pypi/whatportis"
13 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="MIT"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
18 IUSE="test"
19
20 RDEPEND="
21         >=dev-python/click-6.2[${PYTHON_USEDEP}]
22         >=dev-python/prettytable-0.7.2[${PYTHON_USEDEP}]
23 "
24 DEPEND="${RDEPEND}
25         dev-python/setuptools[${PYTHON_USEDEP}]"
26
27 # https://github.com/ncrocfer/whatportis/issues/1
28 RESTRICT="test"
29
30 python_test() {
31         "${EPYTHON}" test_${PN}.py || die
32 }