kde-plasma: Allow to build with kde-frameworks/{baloo,kfilemetadata}
[gentoo.git] / net-misc / vncsnapshot / vncsnapshot-1.2a.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=4
6
7 inherit eutils
8
9 DESCRIPTION="A command-line tool for taking JPEG snapshots of VNC servers"
10 HOMEPAGE="http://vncsnapshot.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ppc x86"
16 IUSE=""
17
18 DEPEND="
19         virtual/jpeg
20         >=sys-libs/zlib-1.1.4"
21 RDEPEND="${DEPEND}"
22
23 src_prepare() {
24         epatch "${FILESDIR}/${P}-amd64grey.patch"
25         sed \
26                 -e 's:-I/usr/local/include::g' \
27                 -e 's:-L/usr/local/lib::g' \
28                 -e '/^all:/s|$(SUBDIRS:.dir=.all)||g' \
29                 -e '/^vnc/s|$| $(SUBDIRS:.dir=.all)|g' \
30                 -i Makefile || die
31 }
32
33 src_compile() {
34         #note: We override CDEBUGFLAGS instead of CFLAGS because otherwise
35         #      we lost the INCLUDES in the makefile.
36         # bug #295741
37         emake CDEBUGFLAGS="${CXXFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)"
38 }
39
40 src_install() {
41         dobin vncsnapshot
42         cp vncsnapshot.man1 vncsnapshot.1
43         doman vncsnapshot.1
44 }