app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / tipcutils / tipcutils-2.0.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5 inherit eutils toolchain-funcs # linux-info
6
7 DESCRIPTION="Utilities for TIPC (Transparent Inter-Process Communication)"
8 HOMEPAGE="http://tipc.sourceforge.net"
9 SRC_URI="mirror://sourceforge/tipc/${P}.tar.gz"
10
11 LICENSE="BSD"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND=""
17 DEPEND=">=sys-kernel/linux-headers-2.6.39"
18
19 S=${WORKDIR}/${P}/tipc-config
20
21 src_prepare() {
22         epatch "${FILESDIR}"/${P}-rename_configuration_message_field.patch
23         sed -i -e '/OFLAGS/s:-O2::' Makefile || die
24 }
25
26 src_compile() {
27         tc-export CC
28         # inherit linux-info and add IFLAGS="${KERNEL_DIR}/include" below in order
29         # to build against headers in /usr/src/linux
30         emake EXTRAS="${CFLAGS}"
31 }
32
33 src_install() {
34         dosbin tipc-config
35 }