app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / streamtuner / streamtuner-0.99.99-r5.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit gnome2
6
7 DESCRIPTION="Stream directory browser for browsing internet radio streams"
8 HOMEPAGE="http://www.nongnu.org/streamtuner"
9 SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.gz
10          https://savannah.nongnu.org/download/${PN}/${P}-pygtk-2.6.diff"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="amd64 ~ppc ~sparc x86"
15 IUSE="python +shout +xiph"
16
17 RDEPEND="
18         >=x11-libs/gtk+-2.4:2
19         net-misc/curl
20         xiph? ( dev-libs/libxml2:2 )
21         >=media-libs/taglib-1.2
22         python? ( dev-python/pygtk:2 )
23         x11-misc/xdg-utils
24 "
25 DEPEND="${RDEPEND}
26         dev-util/gtk-doc-am
27         virtual/pkgconfig
28 "
29
30 src_prepare() {
31         eapply "${FILESDIR}"/${P}-gentoo.patch
32         eapply "${FILESDIR}"/${P}-shoutcast.patch
33         eapply "${FILESDIR}"/${P}-shoutcast-2.patch
34         eapply "${FILESDIR}"/${P}-audacious.patch
35         eapply -p0 "${DISTDIR}"/${P}-pygtk-2.6.diff
36         eapply "${FILESDIR}"/${P}-stack_increase.patch
37
38         # Fix .desktop file
39         sed -i \
40                 -e 's/streamtuner.png/streamtuner/' \
41                 -e 's/Categories=Application;/Categories=/' \
42                 data/streamtuner.desktop.in || die
43
44         gnome2_src_prepare
45 }
46
47 src_configure() {
48         # live365 causes parse errors at connect time
49         # The right value for compile-warning for this is 'yes' (#481124)
50         gnome2_src_configure \
51                 --enable-compile-warnings=yes \
52                 --disable-live365 \
53                 $(use_enable python) \
54                 $(use_enable shout shoutcast) \
55                 $(use_enable xiph)
56 }