app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / streamlink / streamlink-0.1.0.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python{2_7,3_4,3_5} )
7
8 inherit distutils-r1
9
10 DESCRIPTION="CLI for extracting streams from websites to a video player of your choice"
11 HOMEPAGE="https://streamlink.github.io/"
12 SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
13
14 KEYWORDS="~amd64 ~arm ~x86"
15 LICENSE="BSD-2"
16 SLOT="0"
17 IUSE="doc test"
18
19 RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
20         dev-python/requests[${PYTHON_USEDEP}]
21         virtual/python-futures[${PYTHON_USEDEP}]
22         virtual/python-singledispatch[${PYTHON_USEDEP}]
23         media-video/rtmpdump"
24 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
25         doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
26         test? ( ${RDEPEND} )"
27
28 python_compile_all() {
29         use doc && emake -C docs html
30 }
31
32 python_test() {
33         esetup.py test
34 }
35
36 python_install_all() {
37         use doc && local HTML_DOCS=( docs/_build/html/. )
38         distutils-r1_python_install_all
39 }