app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / spiped / spiped-1.6.0-r1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="secure pipe daemon"
7 HOMEPAGE="http://www.tarsnap.com/spiped.html"
8 SRC_URI="http://www.tarsnap.com/${PN}/${P}.tgz"
9
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="amd64 x86"
13 IUSE="libressl"
14
15 MY_PN="${PN/d/}"
16
17 DEPEND="
18         !libressl? ( dev-libs/openssl:0= )
19         libressl? ( dev-libs/libressl:0= )"
20
21 # Blocker added due to #548126
22 RDEPEND="
23         ${DEPEND}
24         !net-mail/qlogtools"
25
26 src_install() {
27         dobin "${MY_PN}/${MY_PN}"
28         dosbin "${PN}/${PN}"
29
30         doman "${MY_PN}/${MY_PN}.1" "${PN}/${PN}.1"
31
32         newinitd "${FILESDIR}/${PN}.initd" "${PN}"
33         newconfd "${FILESDIR}/${PN}.confd" "${PN}"
34
35         dodir "etc/${PN}"
36 }
37
38 pkg_postinst() {
39         elog
40         elog "You will need to configure spiped via its"
41         elog "configuration file located in /etc/conf.d/."
42         elog
43         elog "Please have a look at this file prior to starting up spiped!"
44         elog
45 }