ad4c94916f16f5d3a9d11432b250ae95b8de8b06
[gentoo.git] / net-misc / snarf / snarf-7.0-r3.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=0
5
6 inherit eutils
7
8 IUSE=""
9 DESCRIPTION="Small and fast CLI resource grabber for http, gopher, finger, ftp"
10 SRC_URI="http://www.xach.com/snarf/${P}.tar.gz"
11 HOMEPAGE="http://www.xach.com/snarf/"
12 KEYWORDS="alpha amd64 ppc sparc x86"
13 LICENSE="GPL-2"
14 SLOT="0"
15
16 DEPEND=""
17
18 src_unpack() {
19         unpack ${A}
20         epatch "${FILESDIR}"/snarf-basename-patch.diff
21         epatch "${FILESDIR}"/snarf-unlink-empty.diff
22         epatch "${FILESDIR}"/snarf-fix-off-by-ones.diff
23 }
24
25 src_install() {
26         dobin snarf
27         doman snarf.1
28         dodoc ChangeLog README TODO
29 }
30
31 pkg_postinst() {
32         elog 'To use snarf with portage, try these settings in your make.conf'
33         elog
34         elog '  FETCHCOMMAND="/usr/bin/snarf -b \${URI} \${DISTDIR}/\${FILE}"'
35         elog '  RESUMECOMMAND="/usr/bin/snarf -rb \${URI} \${DISTDIR}/\${FILE}"'
36 }