app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / smbc / smbc-1.2.2-r2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="2"
5
6 inherit autotools eutils
7
8 DESCRIPTION="A text mode (ncurses) SMB network commander. Features: resume and UTF-8"
9 HOMEPAGE="https://sourceforge.net/projects/smbc/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=" ~ppc ~x86"
15 IUSE="nls debug"
16
17 DEPEND="net-fs/samba
18         sys-libs/ncurses
19         dev-libs/popt
20         nls? ( sys-devel/gettext )"
21 RDEPEND="${DEPEND}"
22
23 src_prepare() {
24         epatch "${FILESDIR}"/${P}-cflags.patch
25         epatch "${FILESDIR}"/${P}-size_t.patch
26         eautoreconf
27 }
28
29 src_configure() {
30         econf \
31                 $(use_enable nls) \
32                 $(use_with debug) \
33                 || die "econf failed"
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed"
38         mkdir -p "${D}/usr/share/doc"
39         mv -v "${D}/usr/share/"{${PN},doc/${PF}}
40 }