Use https by default
[gentoo.git] / net-misc / sitecopy / sitecopy-0.16.6-r1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit autotools eutils
7
8 DESCRIPTION="Maintain remote web sites with ease"
9 SRC_URI="http://www.manyfish.co.uk/sitecopy/${P}.tar.gz
10         https://dev.gentoo.org/~idella4/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
11 HOMEPAGE=" http://www.manyfish.co.uk/sitecopy/"
12 # Removed all Debian related stuff.  If you want more patches, they can be ported from
13 # http://ftp.debian.org/debian/pool/main/s/sitecopy/
14 # The sitecopy_0.16.6-5.debian.tar.gz contains their build scripts and patches.
15 # This SiteCopy now builds using the original sources.
16 KEYWORDS="amd64 x86"
17
18 LICENSE="GPL-2"
19 SLOT="0"
20 IUSE="expat nls rsh ssl webdav xml zlib"
21
22 # TODO: Depends copied over from old ebuild file, ensure they're still correct!
23 DEPEND="rsh? ( net-misc/netkit-rsh )
24         >=net-libs/neon-0.24.6[zlib?,ssl?,expat?]
25         <=net-libs/neon-0.30.9999[zlib?,ssl?,expat?]
26         xml? ( >=net-libs/neon-0.24.6[-expat] )"
27 RDEPEND="${DEPEND}"
28
29 src_prepare() {
30         # NOTE: Insert patches here.
31         # SiteCopy patches are being currently pulled & ported from
32         # http://ftp.debian.org/debian/pool/main/s/sitecopy/
33         # Consider SiteCopy to be more or less being actively maintained by
34         # Debian maintainers, but GPL patches ported into Gentoo.
35
36         # NOTE: epatch is provided by 'inherit eutils'
37         # Patch File Naming Format
38         # files/package_name - package_version - patch_order - patch_description
39
40         epatch "${FILESDIR}/sitecopy-0.16.6-01-remote-dynamic-rc.patch" \
41         "${FILESDIR}/sitecopy-0.16.6-02-french-po-fix.patch" \
42         "${FILESDIR}/sitecopy-0.16.6-03-wrong-memory-397155.patch" \
43         "${FILESDIR}/sitecopy-0.16.6-06-sftpdriver.c-fix-for-new-openssh.patch" \
44         "${FILESDIR}/sitecopy-0.16.6-10-bts410703-preserve-storage-files-sigint.patch" \
45         "${FILESDIR}/sitecopy-0.16.6-20-bts549721-add-compatibility-for-neon-0.29.0.patch" \
46         "${FILESDIR}/sitecopy-0.16.6-30-bts320586-manpage-document-sftp.patch" \
47         "${DISTDIR}/sitecopy-0.16.6-04-manpages-addition-fixes.patch"
48
49         # Source package uses incorrect '/usr/doc' for the doc folder.  So use
50         # sed to correct this error.
51         sed -i -e "s:docdir \= .*:docdir \= \$\(prefix\)\/share/doc\/${PF}:" \
52                 Makefile.in || die "Documentation directory patching failed"
53
54         # NOTE: eautoconf/eautomake is provided by 'inherit autotools'
55         # Need to recreate the source package provided configure script,
56         # because the package provided configure script only supports
57         # <neon-0.30.0 support.  A patch above patches the configure.in
58         # providing neon-0.30.0 support, and we then recreate the configure
59         # script based upon configure.in using autotools.
60
61         # First move configure.in to configure.ac, required by newer >autoconf-2.13
62         # per Bug #426262 automake-1.14 compatibility
63         # Should check first, autoconf-2.13 is still in the tree requiring configure.in!
64         # mv configure.in configure.ac || die
65
66         eautoconf
67         eautomake
68 }
69
70 src_configure() {
71         # TODO: USE functions copied over from old ebuild file, ensure they're still correct!
72         econf $(use_with ssl ssl openssl) \
73                 $(use_enable webdav) \
74                 $(use_enable nls) \
75                 $(use_enable rsh) \
76                 $(use_with expat) \
77                 $(use_with xml libxml2 ) \
78                 --with-neon \
79                 || die "econf failed"
80 }
81
82 src_compile() {
83         emake || die "emake failed"
84 }
85
86 src_install() {
87         emake DESTDIR="${D}" install || die "emake install failed"
88 }