sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / net-misc / seafile / seafile-7.0.5-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=(python3_6)
7
8 WANT_AUTOMAKE=1.16
9
10 inherit autotools python-single-r1 vala
11
12 DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
13 HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
14 SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
15
16 LICENSE="GPL-2+-with-openssl-exception"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
21
22 RDEPEND="${PYTHON_DEPS}
23         net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
24         dev-libs/glib:2
25         dev-libs/libevent
26         dev-libs/jansson
27         sys-libs/zlib
28         net-misc/curl
29         dev-libs/openssl
30         dev-db/sqlite:3"
31 DEPEND="${RDEPEND}
32         $(vala_depend)"
33
34 src_prepare() {
35         default
36         sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
37         eautoreconf
38         vala_src_prepare
39 }
40
41 src_install() {
42         default
43         # Remove unnecessary .la files, as recommended by ltprune.eclass
44         find "${ED}" -name '*.la' -delete || die
45         python_fix_shebang "${ED}"/usr/bin
46 }