sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / net-misc / seafile / seafile-6.2.11.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 )
6 inherit autotools python-single-r1 vala
7
8 DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
9 HOMEPAGE="https://github.com/haiwen/seafile/ https://www.seafile.com/"
10 SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2+-with-openssl-exception"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
17
18 RDEPEND="${PYTHON_DEPS}
19         net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
20         dev-libs/glib:2
21         dev-libs/libevent:0
22         dev-libs/jansson
23         sys-libs/zlib:0
24         net-misc/curl
25         dev-libs/openssl:0
26         dev-db/sqlite:3"
27 DEPEND="${RDEPEND}
28         $(vala_depend)"
29
30 src_prepare() {
31         default
32         sed -i -e 's/valac /${VALAC} /' lib/Makefile.am || die
33         eautoreconf
34         vala_src_prepare
35 }
36
37 src_install() {
38         default
39         # Remove unnecessary .la files, as recommended by ltprune.eclass
40         find "${ED}" -name '*.la' -delete || die
41         python_fix_shebang "${ED}"/usr/bin
42 }