app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / s6-networking / s6-networking-2.3.0.2.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit versionator
7
8 DESCRIPTION="suite of small networking utilities for Unix systems"
9 HOMEPAGE="https://www.skarnet.org/software/s6-networking/"
10 SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
11
12 LICENSE="ISC"
13 SLOT="0/$(get_version_component_range 1-2)"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="ssl static static-libs"
16
17 DEPEND=">=sys-devel/make-3.81
18         static? (
19                 >=dev-lang/execline-2.3.0.2[static-libs]
20                 >=dev-libs/skalibs-2.6.0.0[static-libs]
21                 >=net-dns/s6-dns-2.2.0.1[static-libs]
22                 >=sys-apps/s6-2.6.1.0[static-libs]
23                 ssl? ( >=dev-libs/libressl-2.4.5[static-libs] )
24         )
25         !static? (
26                 >=dev-lang/execline-2.3.0.2[static=]
27                 >=dev-libs/skalibs-2.6.0.0
28                 >=net-dns/s6-dns-2.2.0.1[static=]
29                 >=sys-apps/s6-2.6.1.0[static=]
30                 ssl? ( >=dev-libs/libressl-2.4.5 )
31         )
32 "
33 RDEPEND="
34         >=dev-lang/execline-2.3.0.2:=[!static?]
35         >=sys-apps/s6-2.6.1.0:=[!static?]
36         !static? (
37                 >=dev-libs/skalibs-2.6.0.0:=
38                 >=net-dns/s6-dns-2.2.0.1:=
39                 ssl? ( >=dev-libs/libressl-2.4.5:= )
40         )
41 "
42
43 HTML_DOCS="doc/*"
44
45 src_prepare() {
46         default
47
48         # Remove QA warning about LDFLAGS addition
49         sed -i "s/tryldflag LDFLAGS_AUTO -Wl,--hash-style=both/:/" "${S}/configure" || die
50
51         # configure overrides gentoo's -fstack-protector default
52         sed -i "/^tryflag CFLAGS_AUTO -fno-stack-protector$/d" "${S}/configure" || die
53 }
54
55 src_configure() {
56         econf \
57                 --bindir=/bin \
58                 --dynlibdir=/$(get_libdir) \
59                 --libdir=/usr/$(get_libdir)/${PN} \
60                 --with-dynlib=/$(get_libdir) \
61                 --with-lib=/usr/$(get_libdir)/s6 \
62                 --with-lib=/usr/$(get_libdir)/s6-dns \
63                 --with-lib=/usr/$(get_libdir)/skalibs \
64                 --with-sysdeps=/usr/$(get_libdir)/skalibs \
65                 $(use_enable ssl ssl libressl) \
66                 $(use_enable !static shared) \
67                 $(use_enable static allstatic) \
68                 $(use_enable static static-libc) \
69                 $(use_enable static-libs static)
70 }