dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / net-misc / rinetd / rinetd-0.62-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="redirects TCP connections from one IP address and port to another"
9 HOMEPAGE="http://www.boutell.com/rinetd/"
10 SRC_URI="http://www.boutell.com/rinetd/http/rinetd.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE=""
16
17 S=${WORKDIR}/${PN}
18
19 src_prepare() {
20         default
21         sed -i -e "s:gcc:$(tc-getCC) \$(CFLAGS) \$(LDFLAGS):" Makefile
22 }
23
24 src_compile() {
25         emake CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}"
26 }
27
28 src_install() {
29         dosbin rinetd
30         newinitd "${FILESDIR}"/rinetd.rc rinetd
31         doman rinetd.8
32         dodoc CHANGES README index.html
33 }