app-editors/kakoune: drop old 0_pre20160620
[gentoo.git] / net-misc / redir / redir-2.2.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="2"
5
6 inherit eutils toolchain-funcs
7
8 DESCRIPTION="Redir is a port redirector"
9 HOMEPAGE="http://sammy.net/~sammy/hacks/"
10 SRC_URI="http://sammy.net/~sammy/hacks/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha ~amd64 ~hppa ~mips sparc x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND=""
19
20 src_configure() {
21         epatch "${FILESDIR}/${P}-include.patch"
22 }
23
24 src_compile() {
25         emake \
26                 CC="$(tc-getCC)" \
27                 CFLAGS="${CFLAGS}" \
28                 LDFLAGS="${LDFLAGS}" || \
29                 die "emake failed"
30 }
31
32 src_install() {
33         dobin redir || die "dobin failed"
34         newman redir.man redir.1 || die "doman failed"
35         dodoc CHANGES README transproxy.txt || die "dodoc failed"
36 }